Browse Source

Update ReadMe and requirements

- On linux (Debian based) pyrcc5 does not make it onto the path so
updating the notes here to take care of this behavior and update requirements
so virtual environment load it correctly.
- Fix #766
tags/4.1.1
Andrew Senetar 2 months ago
parent
commit
bf5d151799
Signed by: arsenetar <[email protected]> GPG Key ID: C63300DCE48AB2F1
2 changed files with 4 additions and 4 deletions
  1. +3
    -3
      README.md
  2. +1
    -1
      requirements.txt

+ 3
- 3
README.md View File

@@ -62,7 +62,7 @@ dupeGuru comes with a makefile that can be used to build and run:
### Building without Make

$ cd <dupeGuru directory>
$ python3 -m venv --system-site-packages ./env
$ python3 -m venv ./env
$ source ./env/bin/activate
$ pip install -r requirements.txt
$ python build.py
@@ -73,7 +73,7 @@ To generate packages the extra requirements in requirements-extra.txt must be in
steps are as follows:

$ cd <dupeGuru directory>
$ python3 -m venv --system-site-packages ./env
$ python3 -m venv ./env
$ source ./env/bin/activate
$ pip install -r requirements.txt -r requirements-extra.txt
$ python build.py --clean
@@ -81,7 +81,7 @@ steps are as follows:

This can be made a one-liner (once in the directory) as:

$ bash -c "python3 -m venv --system-site-packages env && source env/bin/activate && pip install -r requirements.txt -r requirements-extra.txt && python build.py --clean && python package.py"
$ bash -c "python3 -m venv ./env && source env/bin/activate && pip install -r requirements.txt -r requirements-extra.txt && python build.py --clean && python package.py"

## Running tests



+ 1
- 1
requirements.txt View File

@@ -3,5 +3,5 @@ sphinx>=1.2.2
polib>=1.0.4
hsaudiotag3k>=1.1.3*
distro>=1.5.0
PyQt5 >=5.4,<6.0; sys_platform != 'linux'
PyQt5 >=5.4,<6.0
pywin32>=200; sys_platform == 'win32'

Loading…
Cancel
Save